Ray Dashboard is empty

How severe does this issue affect your experience of using Ray?

  • Low: It annoys or frustrates me for a moment.

I installed ray using following command,
pip install -U “ray[default]”

when I initialize ray using ray.init(include_dashboard=True) or even with just ray.init() it gives me following output,

But when I click the link, the dashboard is empty.
Everything works fine but I’m not able to see anything on the dashboard. It’s just blank screen. I don’t get any errors. I am using Jupyter Notebook.

Can someone please help me resolve this issue?


Can you open your web browser console and see if there are any error messages?

Hello @Huaiwei_Sun,
I can see the following errors

This seems to be the same issue as mentioned in this post? Error 403 for ray dashboard on localhost in ray 2.8.0 on Windows11 - #13 by aguo

Do u also use Windows? If so, which Windows version?

cc: @aguo @Sam_Chan for awareness

Thanks! Based on aforementioned post, I tried downgrading Ray to 2.7.1 and it worked fine. I am using Windows 10.

@TheAdamWarlock can you open up a bug on github?

The bug is fixed here [Dashboard] Fix Path Resolution on Windows by ijrsvt · Pull Request #41388 · ray-project/ray · GitHub and it will be available as part of 2.9 that will come out in mid-Dec