Error 403 for ray dashboard on localhost in ray 2.8.0 on Windows11

How severe does this issue affect your experience of using Ray?

  • High: It blocks me to complete my task.

after installing ray 2.8.0 in Python 3.10.13 on Windows 11, I get working processes and job, but dashboard seems to be broken.

Behavior is kind of strange, as the classic address shows signal but only in the form of an empty / white page. Digging deeper in dev console, I can drill it down to the following two error messages:

GET net::ERR_ABORTED 403 (Forbidden)
GET net::ERR_ABORTED 403 (Forbidden)

As I am not familiar with the technical architecture, what could be sources of root cause behind those?

1 Like

Can try to do hard refresh of your browser pages? It might be due to some code cache.

cc: @aguo

I can confirm this issue.

Tested conda and pip installation for python 3.9 and 3.10 for ray 2.8.0 on Windows 11.

Any updates?

Did you see the same console errors in the browser? @groneber

Yes, exactly the same.

And hard refresh of the page doesn’t work? It might be due to some code cache or something.

No, tried hard refresh and several browsers.
Tomorrow I’ll try to setup the workspace on another machine.

Before my windows 11 update it was working.
I can report my findings.

Thanks! Let us know!

Tested same installation procedure on Windows 10 machine with identical results. It´s still not working.
But it works as expected if i run the test in wsl2 with Ubuntu 22.04.

Perhaps a new company policy has been introduced which blocks access to the relevant files on the server.
I´ll try to validate this with my private pc.

I am having the same issue for ray 2.8.0 on Win10. The dashboard can load when ray is downgraded to 2.7.1.


I am having the same issue for ray 2.8.0 on Win10. The dashboard can load when ray is downgraded to 2.7.1.

I can confirm that the way @Eric_Wong followed is also the short-term remedy for Win11. A downgrade to 2.7.1 is working.

1 Like

That is a lifesaver! Not only, that I realize when I pip install “ray[default]”. it is really slow that it timed out (I am in Asia). So I just rerun pip install like 20 times until it is 100% installed.

When you try sending a request to “” directly either using something like curl or from a new browser window, does the content of that file download? Or do you also get a 403?

I’m not sure what would cause this to break in the new version of ray. This issue seems to be on the side of the dashboard process which serves the static content necessary for the ray dashboard web application. But we did not change anything there recently.

It would be helpful if you could open an issue at Issues · ray-project/ray · GitHub, with a complete reproducer, starting from which python are you using (windows store? conda?), and the commands you are using for installing ray

@mattip : Yes, seems that the root cause is located somewhere in the ray details. I opened the following issue on GitHub.