Required redis version

How severe does this issue affect your experience of using Ray?

  • High: It blocks me to complete my task.

I’m having trouble starting ray because I already have a redis instance (version 5.0.7) running on my development workstation.

When I run ray start --head it fails with the error

Unable to connect to GCS at Check that (1) Ray GCS with matching version started successfully at the specified address, and (2) there is no firewall setting preventing access.

I’ve tried using passing the address of redis using --address but that also fails - it says the primary server is unreachable and a new one will be started. But then I get the same error as above.

If I shutdown my redis server, then run ray start --head it works (but then my application based on redis queue (rq) fails).

So I’m assuming ray depends on a different version of redis to rq but I cannot find what version ray requires. Can someone please point me in the correct direction so I can see if I can find a version that’s mutually compatible.

Hi @david.waterworth, you can try starting Ray on a port different from Redis’, e.g. ray start --head --port=6888, and connect to that address instead e.g. ray start --address=

Most likely Ray’s global control store failed to start because for legacy reasons it also wants to start on port 6379. We will try to improve the error message here.

Ahh yes that works thanks! So it’s not trying to connect to redis, but redis is already using port 6379?

Great! Exactly, Ray trying to connect ot port 6379 is because Ray tries to start its global control store process on port 6379 by default. In this case, the global control store was not started successfully because port 6379 is already used.