Connections to Redis fails with Ray 1.11

Hello guys,
I have followed a new post “Redis in Ray: Past and future” (Anyscale - Redis in Ray: Past and future) and tried to run Ray with Redis.
I ran the command: RAY_REDIS_ADDRESS= ray start –-head
what gave me the Runtime error:

RuntimeError: Unable to connect to Redis at after 16 retries. Check that is reachable from this machine. If it is not, your firewall may be blocking this port. If the problem is a flaky connection, try setting the environment variable RAY_START_REDIS_WAIT_RETRIES to increase the number of attempts to ping the Redis server.

I have running Redis-service in the background and I get the response from it:

redis-cli ping

Do you have any other ideas why I cannot connect to Redis?

Hi @Kordi1818, what is the OS you are using, and can you try RAY_REDIS_ADDRESS= ray start –-head and see if it works?

Thank you @Mingwei for taking time to respond to my message! I’m working on macOS.

Here is the traceback which I get while running: RAY_REDIS_ADDRESS= ray start –-head:

Local node IP:
Traceback (most recent call last):
  File "/Users/kordi/miniconda3/bin/ray", line 8, in <module>
  File "/Users/kordi/miniconda3/lib/python3.9/site-packages/ray/scripts/", line 1958, in main
    return cli()
  File "/Users/kordi/miniconda3/lib/python3.9/site-packages/click/", line 1137, in __call__
    return self.main(*args, **kwargs)
  File "/Users/kordi/miniconda3/lib/python3.9/site-packages/click/", line 1062, in main
    rv = self.invoke(ctx)
  File "/Users/kordi/miniconda3/lib/python3.9/site-packages/click/", line 1668, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/Users/kordi/miniconda3/lib/python3.9/site-packages/click/", line 1404, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/Users/kordi/miniconda3/lib/python3.9/site-packages/click/", line 763, in invoke
    return __callback(*args, **kwargs)
  File "/Users/kordi/miniconda3/lib/python3.9/site-packages/ray/autoscaler/_private/", line 808, in wrapper
    return f(*args, **kwargs)
  File "/Users/kordi/miniconda3/lib/python3.9/site-packages/ray/scripts/", line 621, in start
    node = ray.node.Node(
  File "/Users/kordi/miniconda3/lib/python3.9/site-packages/ray/", line 98, in __init__
  File "/Users/kordi/miniconda3/lib/python3.9/site-packages/ray/_private/", line 805, in wait_for_redis_to_start
  File "/Users/kordi/miniconda3/lib/python3.9/site-packages/redis/", line 1194, in client_list
    return self.execute_command('CLIENT LIST')
  File "/Users/kordi/miniconda3/lib/python3.9/site-packages/redis/", line 898, in execute_command
    conn = self.connection or pool.get_connection(command_name, **options)
  File "/Users/kordi/miniconda3/lib/python3.9/site-packages/redis/", line 1192, in get_connection
  File "/Users/kordi/miniconda3/lib/python3.9/site-packages/redis/", line 567, in connect
  File "/Users/kordi/miniconda3/lib/python3.9/site-packages/redis/", line 643, in on_connect
    auth_response = self.read_response()
  File "/Users/kordi/miniconda3/lib/python3.9/site-packages/redis/", line 756, in read_response
    raise response
redis.exceptions.ResponseError: AUTH <password> called without any password configured for the default user. Are you sure your configuration is correct?

By default, the port is 6379 and there is no password for Redis. Therefore, I’m confused why I’m getting such en error. Any ideas or suggestions?

I usualy delete ray dir in dist-package and pip uninstall ray . then reinstall it.

You can try this method.