2023-03-19 13:38:56,574 WARNING utils.py:1445 -- Unable to connect to GCS at gaowei0155.69.142.146:8901

How severe does this issue affect your experience of using Ray?

  • None: Just asking a question out of curiosity
  • Low: It annoys or frustrates me for a moment.
  • Medium: It contributes to significant difficulty to complete my task, but I can work around it.
  • High: It blocks me to complete my task.

I have problems in runing ray startcommand. Specifically speaking, after I run

ray start --head --port=8901 --num-cpus=8 --redis-password=123456

in server 1, I succeed and get the output:

Next steps
To connect to this Ray runtime from another node, run
ray start --address=‘xx.xx.xx.xx:8901’

However, when I run the command in server 2:

ray start --address=‘@xx.xx.xx.xx:8901’ --num-cpus=8

I get the error:

2023-03-19 14:07:24,808 WARNING utils.py:1445 – Unable to connect to GCS at @xx.xx.xx.xx:8901. Check that (1) Ray GCS with matching version started successfully at the specified address, and (2) there is no firewall setting preventing access.

I make sure that the environment in two servers are identical, and the default port is occupied thus I switch to the port 8901. What’s wrong with that? How could I address this problem?

Hi! Are you able to connect the two nodes on port 8901 without Ray?