Problem installing RLLib on Ubuntu 18.04

  • High: It blocks me to complete my task.

I’m trying to install RLLib on Ubuntu 18.04 using the following: pip3 install “ray[rllib]”

But that generates the following error:

Collecting ale-py~=0.7.1; extra == “atari” (from gym[atari]; extra == “rllib”->ray[rllib])
Could not find a version that satisfies the requirement ale-py~=0.7.1; extra == “atari” (from gym[atari]; extra == “rllib”->ray[rllib]) (from versions: )
No matching distribution found for ale-py~=0.7.1; extra == “atari” (from gym[atari]; extra == “rllib”->ray[rllib])

Is there a way to install RLLib without the extra gym[atari] dependencies or is there another workaround?

Thanks,
Stefan

Are you generating this error from a brand new virtual environment? If not I would recommend making a new one. I think the default RLlib installation (pip3 install “ray[rllib]”) shouldn’t be installing the atari dependencies in the first place.

In the docs, RLlib: Industry-Grade Reinforcement Learning — Ray 1.12.1, you see that they explicit state to:

To be able to run our Atari examples, you should also install:

$ pip install “gym[atari]” “gym[accept-rom-license]” atari_py

So I do not think that doing pip install "ray[rllib]" tensorflow torch (mentioned earlier in the docs) will install them too.

Hi Lucas.

Thanks for getting back to me.

I created a new Conda environment as you suggested and was able to install RLLib without any problems.

I was trying to install RLLib on an AWS/Cloud9 environment, so maybe there is something with that environment that trips up the RLLib installation.

Thanks,
Stefan

1 Like

Hey @steff007 ,

'gym[atari]' is not part of our requirements today and I install it manually after installing ray every time.
Maybe it is for the release that is available for your environment? Does it “still” this? Have you tried with a fresh environment outside of Cloud9? Because a standard 18.04 should work I think.

Cheers