How to run ray tune on two server?

My ray version is 1.9.0

I have encountered similar issue with this one: How to run tune on multiple machines? · Issue #9931 · ray-project/ray · GitHub

I ran ray start --head on server A. It pops out following message:

Local node IP:

Ray runtime started.

Next steps
  To connect to this Ray runtime from another node, run
    ray start --address='' --redis-password='5241590000000000'
  Alternatively, use the following Python code:
    import ray
    ray.init(address='auto', _redis_password='5241590000000000')
  To connect to this Ray runtime from outside of the cluster, for example to
  connect to a remote cluster from your laptop directly, use the following
  Python code:
    import ray
  If connection fails, check your firewall settings and network configuration.
  To terminate the Ray runtime, run
    ray stop

which works fine.
But when I run ray start --address='' --redis-password='5241590000000000' on server B, it throws:

RuntimeError: Unable to connect to Redis at after 16 retries. Check that is reachable from this machine. If it is not, your firewall may be blocking this port. If the problem is a flaky connection, try setting the environment variable `RAY_START_REDIS_WAIT_RETRIES` to increase the number of attempts to ping the Redis server.

I try to ssh server A via ssh on server B it working properly.

Perhaps 6379 is not an open port on server A?

I think there is a firewall problem:

I run nc -zv on Server B and it says Ncat: No route to host.
but when I ping, it works fine:

PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=0.132 ms
64 bytes from icmp_seq=2 ttl=64 time=0.165 ms
64 bytes from icmp_seq=3 ttl=64 time=0.106 ms
64 bytes from icmp_seq=4 ttl=64 time=0.166 ms
64 bytes from icmp_seq=5 ttl=64 time=0.134 ms
64 bytes from icmp_seq=6 ttl=64 time=0.120 ms
64 bytes from icmp_seq=7 ttl=64 time=0.115 ms
64 bytes from icmp_seq=8 ttl=64 time=0.117 ms
64 bytes from icmp_seq=9 ttl=64 time=0.104 ms
64 bytes from icmp_seq=10 ttl=64 time=0.132 ms
64 bytes from icmp_seq=11 ttl=64 time=0.126 ms
64 bytes from icmp_seq=12 ttl=64 time=0.122 ms
--- ping statistics ---
12 packets transmitted, 12 received, 0% packet loss, time 11005ms
rtt min/avg/max/mdev = 0.104/0.128/0.166/0.020 ms

Also ssh works.