Switch off rsync during Cluster Launch

How severe does this issue affect your experience of using Ray?

  • High: It blocks me to complete my task.

I’m trying to launch a single-node ray cluster using ray up.

I have two nodes. One is the node I run ray up from, and the other is to be the head node of the ray cluster. I’ve confirmed that the first node can SSH into the second one.

I’m using exactly the same config.yaml as the one found here - https://github.com/ray-project/ray/blob/master/python/ray/autoscaler/local/example-full.yaml. When I run ray up config.yaml, I get the following error:
FileNotFoundError: [Errno 2] No such file or directory: 'rsync'

I don’t really need the rsync stuff since all the nodes I’m working have a shared NAS mounted on to them. So, I comment out the following fields:

  1. file_mounts
  2. file_mounts_sync_continuously
  3. rsync_filter
    and run ray up config.yaml again, but get the same error.

So, here’s my question - how can I switch off file syncing when running the Cluster Launcher? Or is there an easy way to make my error go away?