Ray start head doesn't start client

Trying to use Ray Client functionality, but nothing seems to work.
Windows 10 v1909, python 3.8, ray 1.2.0

Tried the following:

  1. Just following official doc to: ‘ray start --head’, but port 10001 is not open for connections (checked with netstat).
  2. Tried to manually run (by using the following command: ‘python -m ray.util.client.server’) I get the following console output:

(py38tf) c:\dev\clientactivity>python -m ray.util.client.server
2021-03-04 17:35:27,936 INFO services.py:1172 – View the Ray dashboard at e[1me[32mhttp://[39me[22m
2021-03-04 17:35:36,359 INFO server.py:480 – Starting Ray Client server on
2021-03-04 17:35:41,650 WARNING worker.py:1107 – The dashboard on node TLVCMEW001410 failed with the following error:
Traceback (most recent call last):
File “C:\Users\dm57337.conda\envs\py38tf\lib\site-packages\ray\new_dashboard\dashboard.py”, line 187, in
dashboard = Dashboard(
File “C:\Users\dm57337.conda\envs\py38tf\lib\site-packages\ray\new_dashboard\dashboard.py”, line 81, in init
build_dir = setup_static_dir()
File “C:\Users\dm57337.conda\envs\py38tf\lib\site-packages\ray\new_dashboard\dashboard.py”, line 38, in setup_static_dir
raise OSError(
FileNotFoundError: [Errno 2] Dashboard build directory not found. If installing from source, please follow the additional steps required to build the dashboard(cd python/ray/new_dashboard/client && npm install && npm ci && npm run build): ‘C:\Users\dm57337\.conda\envs\py38tf\lib\site-packages\ray\new_dashboard\client\build’

Port 50051 wasn’t open and not possible to connect with Client API.
Tried to pass the ‘–include-dashboard=false’, but it didn’t work as well:

(py38tf) c:\dev\clientactivity>python -m ray.util.client.server --include-dashboard=false
usage: main.py [-h] [–host HOST] [-p PORT] [–redis-address REDIS_ADDRESS] [–redis-password REDIS_PASSWORD]
main.py: error: unrecognized arguments: --include-dashboard=false

According to official doc, Ray Client should be supported starting from ray version 1.2.0, but it doesn’t seem to work.
Any ideas?

1 Like
Just following official doc to: ‘ray start --head’, but port 10001 is not open for connections (checked with netstat).

is there a stack trace from this step? Can you also verify that after this step, there is a python -m ray.util.client.server process running on the machine?

@rliaw There is a regular stack trace:

(py38) c:\dev\clientactivity>ray start --head --include-dashboard=false
Local node IP:

Ray runtime started.

Next steps
To connect to this Ray runtime from another node, run
ray start --address=‘’ --redis-password=‘5241590000000000’

Alternatively, use the following Python code:
import ray
ray.init(address=‘auto’, _redis_password=‘5241590000000000’)

If connection fails, check your firewall settings and network configuration.

To terminate the Ray runtime, run
ray stop

There are 3 new python processes (besides raylet.exe & Redis…exe processes) created by running the ‘ray start --head’ command.
How can I tell if they are of ‘python -m ray.util.client.server` process’ type?

1 Like

@diman82 what are the names of the processes?

I too am having the same issue (but running on ubuntu 20).

If I run from 2.0.0dev, client-server seems to work as expected, but I get a client timeout with 1.2.0.

1 Like

@rliaw all the 3 processes are ‘python.exe’

Confirmed ray client working with 2.0.0dev on Windows.