Question: How to set SSH port for nodes in auto_scaler YAML?

Hi all.

The SSH port for my server is 1022 rather than the default port (22).
However, when I set the YAML file as follows:

    type: local
    worker_ips: [,]

There will be an error saying that:

ssh: connect to host port 22: Connection refused

SSH still not available (SSH command failed.), retrying in 5 seconds.

Could someone please tell me how to set the port filed for nodes in the YAML file?

Hi @xmzzyo,

I was just looking through the code for a local provider and I did not see a port option. What I did instead was put it in my ssh config file.

For you this would mean creating or editing the .ssh/config file is the home directory of the user and machine you would be starting the ray cluster from.

The config file itself would look something like this

Host 10.0.0.* 
    Port 1022

You could also add LocalForward, IdentityFile and other ssh arguments you might want to set in there.