Installing KubeRay Operator failing

How severe does this issue affect your experience of using Ray?

  • High: It blocks me to complete my task.

Hi there,

I’m trying to install the KubeRay operator according to the documentation using the following command:

kubectl create -k ""

However, I’m getting the following error:
error: trouble checking out href v0.3.0&timeout=90s: exit status 1

I’ve also tried cloning the KubeRay GitHub repo and deploying the configuration using:
kubectl create kuberay\ray-operator\config\default

This throws
error: couldn't make loader for namespace.yaml: got file 'namespace.yaml', but 'C:\Users\...\kustomize-002098603\ray-operator\config\default\namespace.yaml' must be a directory to be a root

I feel like I’m missing something blatantly obvious, but I don’t know what. Any help is appreciated. :slight_smile:


I found my own solution. My client version of kubectl was outdated (1.17). Upgrading to the latest version solved the problem.

1 Like

Hi! Thanks for pointing out the version issue.
Which doc page were you following? We can include a version requirement there so that others don’t run into this.

Thanks for the response! I’ve spent quite some time searching for solutions or alternatives to my problem, so I guess all doc pages related to KubeRay. At least the following documentation pages:

I can only put two links in a post (new user). I found the following Github pages:

Perfect, thanks. Doc amendments: