[Clusters] Node ip not respected for head node?

In my setup my nodes have multiple NICs and ray chooses the default NIC over the configured node ip address. This leads to a lot of issues as the head node is not available from the default NIC. Is there a way to disable this behaviour?

My start command:

ray start --head --port=6379 --dashboard-host= --node-ip-address= --autoscaling-config=~/ray_bootstrap_config.yaml

But the nodes starts with the wrong IP:

Thanks for the report, I created an issue here: [cluster] Make node_ip_address work throughout · Issue #15239 · ray-project/ray · GitHub

Feel free to contribute more information about what is broken here to the issue. If only the dashboard is broken that seems like a minor issue but based on your description it sounds like more things are broken here, right?

The setting is propagated through ray/main.cc at master · ray-project/ray · GitHub and some other files like ray/services.py at 29566c35276d5b8620fef717c92f20c8c6539099 · ray-project/ray · GitHub.

If you can pin-point more which component is causing issues (e.g. from log files) we can help identify where in the code problems could be coming from. PRs are also very welcome :slight_smile: