Unsuccessful task submission to an existing ray cluster

How severe does this issue affect your experience of using Ray?

  • High: It blocks me to complete my task.

I’m using AZURE, I deployed a small test cluster via the example-full.yaml file ;

After deploying the cluster I tried to submit my task using ray submit;

then I encountered a connection timeout error (I deployed the above small ray cluster on a GUI-less ubuntu, from which I submitted the task to the cluster), here are some detailed pictures:

(I set the number of cpu’s provided by the head nod to 0 as per the documentation hints and after deployment I got a ray cluster with only one head nod at the moment.)

(The series of pythons I want to run on the ray cluster are in the /home/chou/123 folder)

(I ran a ping test from chou-ubuntu to the public ip of the head nod and found that the connection could not be established)

Hello everyone, this problem has been solved, not the reason of the firewall, with ray address designation has a relationship, I can not specify the deep reason, and I will summarize after I get clear and accurate knowledge from ray documents.