The same code behaves differently

How severe does this issue affect your experience of using Ray?

  • High: It blocks me to complete my task.

I have have stumbled upon this nice library called Modin, and this library uses Ray.
To test it, i made a script to see if it works better or worse that the ordinary Pandas. This worked very nicely with Ray on my local machine, but my machine isn’t powerful enough to get a good result, so I got my hands on a really powerful server to run it on. I have then copied my script and all dependencies over to the server, and running it there.
On my local machine, when I import Ray, and initializes it in the beginning, it just goes straight to the code itself.
But on the server, it behaves very differently, apparently. So when I run the script, it starts what I suspect is a virtual environment or localhost. After that, it gives me a lot of prints with the ‘UserWarning’ classification. After some time, it just fails saying that:

The raylet exited immediately because the Ray agent failed. The raylet fate shares with the agent. This can happen because the Ray agent was unexpectedly killed or failed. See dashboard_agent.log for the root cause.

I have absolutely not idea why it fails on my server and not on my local machine. They run the exact same code, with the exact same dependencies within an identical Pyenv. So I’m a little lost here, and honestly I don’t know if this error is more related to the Modin library rather than Ray

I hope someone can help me in some way

Can you show me the log from dashboard_agent.log? It exists in /tmp/ray/session_latest/dashboard_agent.log. I am also down to do pair debugging through a call if you are open to it.

Hi, I have found out that it’s more likely that it’s a problem with the library Modin, than with Ray. The problem happens when it reaches my pd.DataFrame.Melt function.

Unfortunately I’m not able to upload the file that you are requesting, due to the file type limitation of the upload function on the website.