The example pendulum-mbmpo.yaml gives an error when I run it

At first, when I run tuned exampl example pendulum-mbmpo.yaml, it always returns the error message:
(MBMPO pid=3356237) RuntimeError: split_with_sizes expects split_sizes to sum exactly to 32 (input tensor’s size at dimension 0), but got split_sizes=[30]

I’ve found that this is easily fixed by changing the num_workers to 1 or 2.
But right now my task never runs:
│ Trial name status │
│ MBMPO_ray.rllib.examples.env.mbmpo_env.PendulumWrapper_ed61e_00000 PENDING │

I used command to run: rllib train --local-mode file tuned_examples/mbmpo/pendulum-mbmpo.yaml

Even when I follow Installation guide commands and run simple example:
$ conda create -n rllib python=3.8
$ conda activate rllib
$ pip install “ray[rllib]” torch “gym[atari]” “gym[accept-rom-license]” atari_py
$ # Run a test job:
$ rllib train --run APPO --env CartPole-v0 --torch

I get error:
No such option: --torch (Possible options: --restore, --stop, --trace)

This happens on both Ubuntu 22.04 and WSL2. I use ray, version 2.6.3

What should I do to use this ray example with MBMPO?