'serve start' from command line fails

hi, I’m playing with the nightly built version of ray. I got an error, when I tried ‘serve start’ from the command line:

'RuntimeError: serve.start(detached=True) should not be called in anonymous Ray namespaces because you won’t be able to reconnect to the Serve instance after the script exits. If you want to start a long-lived Serve instance, provide a namespace when connecting to Ray. See the documentation for more details: Using Namespaces — Ray v2.0.0.dev0

But it seems no place for me to pass a namespace from this interface.

Any thought?

My ray version is: ray, version 2.0.0.dev0, and my python version is 3.8


Thanks for reporting this @blshao84! I filed a bug to track it on GitHub and we should be able to fix it soon:

I notice this bug was fixed a few days ago, but after I upgrade ray to the latest nightly build, there’s still such an error. Here’s the way I did my upgrade:
pip install -U https://s3-us-west-2.amazonaws.com/ray-wheels/latest/ray-2.0.0.dev0-cp38-cp38-manylinux2014_x86_64.whl

I also tried install from a specific commit like this:
pip install -U https://s3-us-west-2.amazonaws.com/ray-wheels/master/8d56a36d28535fb64961327b037d8553700d7e4f/ray-2.0.0.dev0-cp38-cp38-manylinux2014_x86_64.whl, but still no luck.

Am I doing something wrong?

aha, I figure it out. I have to pip uninstall ray first. Probably it worth mentioning on the documentation.