Running tasks only on workers

How severe does this issue affect your experience of using Ray?

  • High: It blocks me to complete my task.

Is there a way to run my tasks/functions only on workers and not on my head node? Basically I want to use my head node just to give instructions and not do any kind of processing/computation.

Thank you

the typical pattern is to use num-cpus=0 when you start a head node.

Other option is to add custom resources to all worker nodes ({“worker”:1 }), and require this to your tasks/actors