[RecSys Implementation] TypeError: 'Box' object is not subscriptable

How severe does this issue affect your experience of using Ray?

  • High: It blocks me to complete my task.

Hello everyone,

I would like to seek assistance regarding an issue I encountered while running an example code from a GitHub repository. The code is related to a recommender system with RecSim, and the specific file I’m referring to is located here:

When I ran the code without making any modifications, I encountered the following error:

File "D:\Documents\Project\rllib\.env-rllib\lib\site-packages\ray\rllib\algorithms\slateq\slateq_torch_model.py", line 34, in __init__ self.embedding_size = self.orig_obs_space["doc"]["0"].shape[0] TypeError: 'Box' object is not subscriptable

I haven’t made any changes to the code and I tried running it with both PyTorch and TensorFlow with same command, but I still encountered the same error.
python .\examples\recommender_system_with_recsim_and_slateq.py --local-mode

I curious, is the error related to the SlateQ impelementation slateq_torch_model.py and slateq_tf_model.py file, because when I used the DQN model, it worked without any issues. However, I’m having trouble understanding the exact cause of the error.
I think this part cause the error.

I would greatly appreciate any help or suggestions to resolve this issue.
Thank you in advance.