Ray.init(remote address) terminates the parent process

My code executed from a Process that I started. The code simply connects to the Ray cluster

    print ("Before Ray init")
    ray.init(address='IP:PORT', _redis_password='123', logging_level=logging.DEBUG)
    print ("After Ray init")
except Exception as e:
    print (e)

When this code executed, the Process is terminated right after ray.init.. and line After Ray init is never printed. However when i replace

ray.init(address='IP:PORT', _redis_password='123', logging_level=logging.DEBUG)



Then Process doesn’t terminates and line After Ray init is printed.
Any ideas what might cause this issue? Anything in my environment is wrong?

Quick Question - Are you on windows?

No…it’s Linux based, I run a process from Docker image
I use Ray 2.2.0.dev0, Python 3.7.7

To give more details, this is the code i am running

def test(val):
  class T():
    def __init__(self):
    def run(self):
        print ("before Ray init")
        ray.init(address='IP:PORT', _redis_password='123')
        print ("after Ray init")

    import ray
    from multiprocessing import Process
    jr = T()
    jrp = Process(target=jr.run)
    print('JR process finished')
    if jrp.is_alive():
      print ("Alive")
     print ("Dead process")

So when i run it, i am getting prints

before Ray init
INFO worker.py:665 -- Connecting to existing Ray cluster at address: IP:PORT
JR process finished
Dead process

I wonder, is this something related the env? I execute this code form a remote machine. Some permissions may be? I don’t know what ray.init(…) expects to have and then some issue may cause the process to die.

so i guess it all failed for me since i did ray.init(adress=..) outside of the Ray cluster, and ray.init(…) only works internally to Ray cluster