It doesn't work for kuberay set a working_dir to a local zip file

It is work, when I run the sample config of kuberay as following file:

But when I change the value of working_dir to a local file path (the file is download by above link):

working_dir: "file:///home/k8s/lin-test-ray/"
working_dir: "file:/home/k8s/lin-test-ray/"

The service has something wrong, and output of kubectl describe are:

  Active Service Status:
    App Status:
    Dashboard Status:
    Ray Cluster Status:
      Available Worker Replicas:  1
      Desired Worker Replicas:    1
        Client:             10001
        Dashboard:          8265
        Dashboard - Agent:  52365
        Gcs - Server:       6379
        Metrics:            8080
        Serve:              8000
        Pod IP:   
        Service IP:
      Last Update Time:     2023-08-17T10:07:23Z
      Max Worker Replicas:  5
      Min Worker Replicas:  1
      Observed Generation:  1
      State:                ready
  Observed Generation:      1
  Pending Service Status:
    App Status:
      Health Last Update Time:  2023-08-17T10:07:29Z
      Last Update Time:         2023-08-17T10:08:26Z
      Status:                   DEPLOYING
    Dashboard Status:
      Health Last Update Time:  2023-08-17T10:08:26Z
      Is Healthy:               true
      Last Update Time:         2023-08-17T10:08:26Z
    Ray Cluster Name:           rayservice-sample-raycluster-xrt2z
    Ray Cluster Status:
  Service Status:  WaitForServeDeploymentReady

  Type    Reason                       Age                    From                   Message
  ----    ------                       ----                   ----                   -------
  Normal  WaitForDashboard             6m32s (x2 over 6m33s)  rayservice-controller  Service "rayservice-sample-raycluster-prgjs-dashboard-svc" not found
  Normal  WaitForServeDeploymentReady  6m25s (x7 over 6m31s)  rayservice-controller  Put "http://rayservice-sample-raycluster-prgjs-dashboard-svc.default.svc.cluster.local:52365/api/serve/deployments/": dial tcp connect: connection refused
  Normal  ServiceNotReady              6m7s (x8 over 6m21s)   rayservice-controller  The service is not ready yet. Controller will perform a round of actions in 2s.
  Normal  SubmittedServeDeployment     92s (x143 over 6m21s)  rayservice-controller  Controller sent API request to update Serve deployments on cluster rayservice-sample-raycluster-prgjs

What Happen? Can I use the local zip file?
Thank you very much!

I solved the problem as:

  1. mount the zip file to all containers;

  2. the value format of working_dir is

working_dir: "file:///tmp/data/"