Is `streaming_py_proto` exist in any BUILD.bazel?

I tried run bazelisk build -c fastbuild //:ray_pkg to build ray. And I got error message below.

ray/streaming/BUILD.bazel:316:21: in deps attribute of _rule rule //streaming:streaming_py_proto: rule '//streaming:streaming_proto' does not exist. Since this rule was created by the macro 'python_proto_compile', the error might have been caused by the macro implementation

Then, I searched the whole ray project to find streaming_py_proto, however I could not found any BUILD.bazel contain name="streaming_py_proto".

I wondered that this streaming_py_proto was built by another command?

Hmm I’ve never seen this issue. Before we going further, can I ask you if the issue still exists when you don’t specify fastbuild in your bazel command ?

Yes, it was still existed.

By the way, is there any instruction for developing ray with vscode?

Hmm, I m in master branch. XD

No special instruction. I use vscode, but I don’t have any special setup.

Can you try bazel clean --expunge and try again
?

Thx, sangcho. I solved this problem yesterday.

I ran gazelle that modified BUILD.bazel files.
I hated gazelle :joy: