Installing Ray [Rllib] on Power-9 Architecture?

How severe does this issue affect your experience of using Ray?

  • High: It blocks me to complete my task.

Is it possible to get Rllib on power-9 linux architecture? I’ve tried installing the wheels but it tells me that they are not supported on my platform.

I’m essentially wondering if I’m missing something (e.g. can source+compile pip packages be installed somehow? Are there any stories of people successfully installing on power-9?), which could allow me to avoid building from source manually (I also am unsure if it is possible to use docker on my system).

So far I’ve tried both the anaconda package & pip, but nothing more advanced than that.

P.S. I see that Rlib at least advertises support for IBM HPC clusters. This seems to imply that it should work on power9 right?

Hey @Prof_Plum , thanks for this question. I changed to topic to “Ray Core” for better matching.

@Clark_Zinzow , could you or someone from your team answer this question? Thanks :slight_smile:

Hi @Prof_Plum Ray doesn’t have official support for power-9 architecture. I haven’t heard other users installing on power-9. One thing you may try is to build Ray on your power-9 machine. You can find the steps at here (for other architectures): Building Ray from Source — Ray 2.0.0.dev0, which may serve as a reference to build on power-9.

I’m looking into this as well. It seems like building python only won’t be an option on power 9 architectures since the wheel (pip install -U is not for Power 9. So it seems we’ll have to try a full build. I’ll give this a try and update as I make progress.

1 Like

I’ve been hinderd by the need for sudo in order to build ray from scratch. I won’t be able to get this on my machine, so it’s unlikely I’ll be able to make more progress here. Sorry :frowning: