Increase tune's concurrent trials to trigger Autoscaling

How severe does this issue affect your experience of using Ray?

  • Medium: It contributes to significant difficulty to complete my task, but I can work around it.

I’m running ray.tune trials on a ray cluster. My problem is that ray.tune only runs “the number of CPUs” concurrent trials on the head node. How could I increase the number of concurrent trials manually to trigger cluster’s autoscale?

-------- PS -------
I understand that I can specify CPU resources for each trial. However, in my case each trial only needs 1 CPU. I only want to increase the number of concurrent trials.

We’ve discussed this on slack before, but I’m pasting my answer here for future reference:

The default for this setting depends on the search algorithm - but autoscaling should still be triggered always if you request more trials than can fit on the current cluster and if the cluster is configured for autoscaling.If you want to increase autoscaling speed, you can try to adjust the TUNE_MAX_PENDING_TRIALS_PG environment variable.