Explicitly setting number of CPUs on node

How severe does this issue affect your experience of using Ray?

  • Medium: It contributes to significant difficulty to complete my task, but I can work around it.

As noted in this topic, detection of the number of CPUs isn’t always correct on Docker. Is there a way to override the number of logical CPUs detected on a cluster node, e.g., when using the cluster with ray.tune?

There’s a Ray start parameter for this:
ray start --num-cpus 10

Doc reference on ray start: