# ValueError: Attempting to cap object store memory usage at 67108864 bytes, but the minimum allowed is 78643200 bytes

**URL:** <https://discuss.ray.io/t/valueerror-attempting-to-cap-object-store-memory-usage-at-67108864-bytes-but-the-minimum-allowed-is-78643200-bytes/1294>\
**Category:** Ray Core\
**Created:** [March 17, 2021, 3:19pm UTC](https://discuss.ray.io/t/valueerror-attempting-to-cap-object-store-memory-usage-at-67108864-bytes-but-the-minimum-allowed-is-78643200-bytes/1294 "2021-03-17T15:19:17Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![diman82](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.ray.io/diman82/32/407_2.png) [@diman82](https://discuss.ray.io/u/diman82)\
**Post date:** [March 17, 2021, 3:19pm UTC](https://discuss.ray.io/t/valueerror-attempting-to-cap-object-store-memory-usage-at-67108864-bytes-but-the-minimum-allowed-is-78643200-bytes/1294/1 "2021-03-17T15:19:17Z")

</div>

I’m getting the following error when running in docker container (OpenShift is the orchestrator).  
What is the best way to resolve this error?

---

<div class="post-metadata">

**Author:** ![sangcho](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.ray.io/sangcho/32/425_2.png) [@sangcho](https://discuss.ray.io/u/sangcho)\
**Post date:** [March 17, 2021, 5:44pm UTC](https://discuss.ray.io/t/valueerror-attempting-to-cap-object-store-memory-usage-at-67108864-bytes-but-the-minimum-allowed-is-78643200-bytes/1294/2 "2021-03-17T17:44:18Z")

</div>

This literally means the plasma store memory limitation of your docker container is too low (60MB). Ray requires at least 75~isMB of memory in your machine available.

Note that Ray automatically set 30% of your machine (container) memory for plasma store. That says there are two solutions;

1. Increase the memory capacity of your container. I think your container probably has 200~isMB of memory limitation.
2. Specify the plasma store memory larger explicitly when you start a Ray instance. e.g., ray start --object-store-memory=$(100_1024_1024). This is not recommended.

---

<div class="post-metadata">

**Author:** ![diman82](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.ray.io/diman82/32/407_2.png) [@diman82](https://discuss.ray.io/u/diman82)\
**Post date:** [March 18, 2021, 11:01pm UTC](https://discuss.ray.io/t/valueerror-attempting-to-cap-object-store-memory-usage-at-67108864-bytes-but-the-minimum-allowed-is-78643200-bytes/1294/3 "2021-03-18T23:01:49Z")

</div>

@sangcho Can you please elaborate re 2nd option? I’m not running a real cluster so how to set it for ray.init(local\_mode=True)?

P.S I’ve re-checked, and request & limit for containers are set to 8GB! Pods are created in OpenShift v4.5. Plasma dir is /tmp

---

<div class="post-metadata">

**Author:** ![sangcho](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.ray.io/sangcho/32/425_2.png) [@sangcho](https://discuss.ray.io/u/sangcho)\
**Post date:** [March 19, 2021, 10:20pm UTC](https://discuss.ray.io/t/valueerror-attempting-to-cap-object-store-memory-usage-at-67108864-bytes-but-the-minimum-allowed-is-78643200-bytes/1294/4 "2021-03-19T22:20:06Z")

</div>

That’s pretty weird. Usually when ray is started (by `ray start --head` for example), it uses the 30% of the machine memory for object store memory. And you can overwrite this whenever you want to in this way;

```auto
ray start --head --object-store-memory=[memory_in_bytes]

```

You can also do this when you start ray from a python script.

```python3`  
ray.init(object\_store\_memory=[memory\_in\_bytes])

```auto

```

---

<div class="post-metadata">

**Author:** ![diman82](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.ray.io/diman82/32/407_2.png) [@diman82](https://discuss.ray.io/u/diman82)\
**Post date:** [March 20, 2021, 7:34pm UTC](https://discuss.ray.io/t/valueerror-attempting-to-cap-object-store-memory-usage-at-67108864-bytes-but-the-minimum-allowed-is-78643200-bytes/1294/5 "2021-03-20T19:34:13Z")

</div>

@sangcho Thanks, using the ‘object\_store\_memory’ param has resolved the issue.
