# Using private docker image fail (AWS EC2)

**URL:** <https://discuss.ray.io/t/using-private-docker-image-fail-aws-ec2/11212>\
**Category:** Ray Clusters\
**Created:** [June 30, 2023, 10:56am UTC](https://discuss.ray.io/t/using-private-docker-image-fail-aws-ec2/11212 "2023-06-30T10:56:23Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![numpie](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.ray.io/numpie/32/4669_2.png) [@numpie](https://discuss.ray.io/u/numpie)\
**Post date:** [June 30, 2023, 10:56am UTC](https://discuss.ray.io/t/using-private-docker-image-fail-aws-ec2/11212/1 "2023-06-30T10:56:23Z")

</div>

High:

When I launch ray cluster with docker private repository, console shows error message that

“Error response from daemon: pull access denied for [repo name], repository does not exist or may require ‘docker login’: denied: requested access to the resource is denied” .

Even though finished ‘docker login’, it still fails. How do I get ray to access my repository with my docker credentials?
