Pipenv installation fails for gpustat


Trying to install ray==1.9.1 in my project it fails for the below error:

ERROR: ERROR: Could not find a version that matches gpustat>=1.0.0b1

The setup.py in ray has a default "gpustat >= 1.0.0b1", # for windows. Can this be made optional.?
I want to upgrade ray to use the latest stable features.

pipenv = 2018.11.26
pip = “*”
python = “3.9.9”

What OS are you on? I was able to pip install gpustat==1.0.0b1 on both Ubuntu and MacOS for Python 3.9.

Hi @Clark_Zinzow the pip installation works. Its more of a pipenv issue I believe. Since gpustat has a pre-release version pipenv is unable to resolve it. Is there anyway Ray can change the default requirement of gpustat to a stable release version instead of a pre-release version?
Cc: @sangcho

@satishdash Got it. Are you willing to allow this pre-release version? If so, you can ask pipenv to allow pre-release packages: Frequently Encountered Pipenv Problems — pipenv 2020.6.2.dev0 documentation

Pipenv does not install pre-releases (i.e. a version with an alpha/beta/etc. suffix, such as 1.0b1 ) by default. You will need to pass the --pre flag in your command, or set

[pipenv] allow_prereleases = true

in your Pipfile.